After investigation by our Infrastructure team, they concluded that due to a server restart after deleting the files in question there is no option of recovery of the deleted files. We are implementing procedures to mitigate deletion in the future and our development team is improving error handling to give better feedback to users of the website.
Posted Jan 28, 2026 - 18:13 CET
Identified
The issue has been identified. During the server updates on January 23rd (refer to https://ibexgaming.statuspage.io/incidents/s1m00vznpf6t), our Server Administrators have opted to re-install the gameserver. This inadvertantly caused all Demos that were stored in the gameserver directory to be deleted. We are checking if there are any ways of recovering the demos prior to January 23rd.
Posted Jan 28, 2026 - 18:06 CET
Investigating
We have been informed that our Demo Downloader Website is currently returning an error to all visitors. We are investigating the issue.